B15U.com - A Nissan Sentra Forum
Page 1 of 2 12 LastLast
Results 1 to 20 of 30

Thread: P0507 code???

  1. #1
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default P0507 code???

    So today i cleaned the throttle body on my car. When i started the car it started idling jumps from 1.5k to 2k RPM really annoying i was like WTF after driving for about 5 minutes got a check engine light. plugged in the code reader gave me a p0507 Idle control system RPM high. What can that be how can i fix it.Car runs good except when in neutral it revs up and down

  2. #2
    Senior Member MIKE
    Join Date
    Nov 2009
    Location
    STATEN ISLAND
    Posts
    2,152
    Rides
    1
    Drives
    02 maxima
    Likes Received
    16

    Default Re: P0507 code???

    ohh man neverrrrr clean the tb on our cars... well u can clean em never touch the plate inside( the flap) now u have to do the idle relearn to fix it...

  3. #3
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default Re: P0507 code???

    i tried it but couple times but not sure if im doing it right doesnt seem to work

  4. #4
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default Re: P0507 code???

    i should of known better to ask first

  5. #5
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default Re: P0507 code???

    Well after researching this helped went through the whole thing but still idling high

    check link out [ame=http://www.youtube.com/watch?v=M62kkenI_Ro]YouTube - Nissan P0505 P0507 Relearn Cam and Crank Sensor Troubleshooting and Testing by Wells[/ame]

  6. #6
    Senior Member MIKE
    Join Date
    Nov 2009
    Location
    STATEN ISLAND
    Posts
    2,152
    Rides
    1
    Drives
    02 maxima
    Likes Received
    16

    Default Re: P0507 code???

    o the idle relearn from this forum...ull find it in search...make sure u have a timer with u( stopwatch) and time becuase it aint gunna work on the first try( maybe if your lucky) it took me about 10 times for mine to relearn...keep trying man!

  7. #7
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default Re: P0507 code???

    I got it to go all the way through with the flashing mil light and all but still idles high.

  8. #8
    Senior Member BIG AL
    Join Date
    Jul 2009
    Location
    QNZ
    Posts
    2,167
    Rides
    2
    Drives
    04 SPEC V
    Likes Received
    31

    Default Re: P0507 code???

    Try this unplug the t/b for about 20mins then plug it back in scan & clear all the code. Then start the car & run it for about 5min. Then do the idle relearn that should fix your problem. Oh yeah did you mess with the MAF also?
    Big J: "Who gives a damn, some people open a tool box, some people open a wallet to build a car, the end results are the end results."

    CATCH ME IF U CAN

  9. #9
    Apprentice Daniel
    Join Date
    Jul 2009
    Location
    Brooklyn, NY USA
    Posts
    658
    Drives
    2004 Turboed Nissan Sentra SE-R Spec V
    Likes Received
    2

    Default Re: P0507 code???

    Make sure you have no vacuum leaks.
    Herniated Disc - Having back problems? Learn about treatment options.

    Good things do come to those who wait, but only the things that are left behind by those who hustle. - Abraham Lincoln

  10. #10
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default Re: P0507 code???

    Quote Originally Posted by cupit867 View Post
    Try this unplug the t/b for about 20mins then plug it back in scan & clear all the code. Then start the car & run it for about 5min. Then do the idle relearn that should fix your problem. Oh yeah did you mess with the MAF also?


    I didnt mess with the MAF but Im going to try this out. thanks

  11. #11
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default Re: P0507 code???

    Quote Originally Posted by cupit867 View Post
    Try this unplug the t/b for about 20mins then plug it back in scan & clear all the code. Then start the car & run it for about 5min. Then do the idle relearn that should fix your problem. Oh yeah did you mess with the MAF also?

    So I just gave this a try and it worked Just want to say thanks for all the help. I was ready to give up and just make a appointment with Nissan tomorrow to take it in and get checked out. Thanks again greatly appreciated for those who helped

  12. #12
    Newbie
    Join Date
    May 2010
    Posts
    121
    Likes Received
    5

    Default

    im having this identical problem but with no code. is it absolutely necessary to clear all the codes after unplugging the TB for a while if you were never throwing a code? it's sitting right now with unplugged, im trying to be patient with it and give it a while...

    edit: didnt work- any other ideas? i now have a code though, but still same problem... http://www.b15sentra.net/forums/show...=1#post2618812

  13. #13
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default

    Quote Originally Posted by khan View Post
    im having this identical problem but with no code. is it absolutely necessary to clear all the codes after unplugging the TB for a while if you were never throwing a code? it's sitting right now with unplugged, im trying to be patient with it and give it a while...

    edit: didnt work- any other ideas? i now have a code though, but still same problem... yet another idle issue - yes i did my research - help me out - B15sentra.net - Nissan Sentra Forum
    unplug your battery over night then try it again it worked for me after doing it a couple times.

    Try this unplug the t/b for about 20mins then plug it back in scan & clear all the code. Then start the car & run it for about 5min. Then do the idle relearn that should fix your problem.


    SCROLL UP TO THE 5TH POST WATCH THE VIDEO WILL GIVE YOU A BETTER IDEA ON HOW TO DO IT. THAT HELPED ME ALSO.ITS DONE ON A ALTIMA BUT IT WORKS

  14. #14
    Senior Member BIG AL
    Join Date
    Jul 2009
    Location
    QNZ
    Posts
    2,167
    Rides
    2
    Drives
    04 SPEC V
    Likes Received
    31

    Default

    Quote Originally Posted by specV04 View Post
    So I just gave this a try and it worked Just want to say thanks for all the help. I was ready to give up and just make a appointment with Nissan tomorrow to take it in and get checked out. Thanks again greatly appreciated for those who helped
    Ur welcome glad to help out.
    Big J: "Who gives a damn, some people open a tool box, some people open a wallet to build a car, the end results are the end results."

    CATCH ME IF U CAN

  15. #15
    Newbie
    Join Date
    May 2010
    Posts
    121
    Likes Received
    5

    Default

    yeah i did the relearn like 35 times, ive got that shit down like nobody's business. always with a stop watch, too.

    no luck with unplugging the tb or battery, but i only tried the battery for an hour. ill try it tonight all night... maybe i should leave the tb unplugged too? i dunno if that would make any difference if the battery is already unplugged...

  16. #16
    Senior Member BIG AL
    Join Date
    Jul 2009
    Location
    QNZ
    Posts
    2,167
    Rides
    2
    Drives
    04 SPEC V
    Likes Received
    31

    Default

    Quote Originally Posted by khan View Post
    yeah i did the relearn like 35 times, ive got that shit down like nobody's business. always with a stop watch, too.

    no luck with unplugging the tb or battery, but i only tried the battery for an hour. ill try it tonight all night... maybe i should leave the tb unplugged too? i dunno if that would make any difference if the battery is already unplugged...
    do you have any codes? which codes are coming up? If you do have clear the code & try it again.
    Big J: "Who gives a damn, some people open a tool box, some people open a wallet to build a car, the end results are the end results."

    CATCH ME IF U CAN

  17. #17
    Newbie Alex
    Join Date
    Jun 2010
    Location
    The Windy City
    Posts
    61
    Drives
    04 SE-R Spec V
    Likes Received
    0

    Default

    you might have some other problem i tried it about a good ten times before i got it to work.I did it to my friends spec V and it worked on the first try.Check to see what codes you have.

  18. #18
    Newbie
    Join Date
    May 2010
    Posts
    121
    Likes Received
    5

    Default

    it's that p0507 again, naturally... i couldn't hear any leaks while my friend kicked the throttle, but im 90% sure i can hear a vacuum hiss while im driving in 2nd and 3rd giving it only a moderate amount of gas.

    im thinking it must be a leak if i can hear it, but for the life of me i cant find it. i tightened everything and checked the TB gasket. i dont want to have to get into the manifold, but i may have to. the only thing holding me back is that there was no leak prior to removing the intake and doing this evidently disasterous cleaning. i never touched the manifold except the TB, so i dont know how it could have "sprung" a leak like that.

  19. #19
    Senior Member MIKE
    Join Date
    Nov 2009
    Location
    STATEN ISLAND
    Posts
    2,152
    Rides
    1
    Drives
    02 maxima
    Likes Received
    16

    Default

    ^^ if you dont wanna take shit apart...open ur hood...get some wd40 spray and spray around ur intake...like where the gasket wuld be or w>e if you see the spray getting suckd in...u have a leak =)

  20. #20

    Default

    i am a newbie herre, and this site is awesome, i have an scan tool, i have scanned my sentra and receive the p05007 code i follow the instructions on the video but i cant get the mill to stay steady after it blinks am i doing something wrong please help....this is killing me

 

 
Page 1 of 2 12 LastLast

Similar Threads

  1. P0507 high rpm?..
    By PooMnky in forum B15 Sentra (2000 - 2006)
    Replies: 4
    Last Post: 04-19-2010, 12:27 PM
  2. need help Code p0171
    By Sideswipe in forum Troubleshooting and Support
    Replies: 4
    Last Post: 10-08-2009, 10:56 PM
  3. po420 code
    By dawhitespecv in forum B15 Sentra (2000 - 2006)
    Replies: 18
    Last Post: 10-30-2008, 01:21 PM
  4. p0507 code?
    By mamut in forum B15 Sentra (2000 - 2006)
    Replies: 9
    Last Post: 08-24-2007, 05:25 PM
  5. Code 0420
    By illoosionz in forum B15 Sentra (2000 - 2006)
    Replies: 6
    Last Post: 03-30-2006, 11:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •