A Nissan Sentra Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
So this is a weird one. I think I only found one other thread about this but my Spec-V has developed a weird issue where it dies on the freeway at high RPMS if you immediately shift into neutral to coast. This isn’t like a lugging the engine issue. You could be in 5th driving between 4 and 5K and if you slow down and try coasting into neutral, the RPMs drop and the car stalls. It starts right back up if you get into gear again but this issue only happens coasting in neutral after high RPMs. I saw one thread say it could be a clogged fuel pump or either cam or crank sensor but I’m wondering if anyone in the time since might’ve dealt with it or know a good way to diagnose it outside of taking it to a shop.
 

·
Registered
04 spec v
Joined
·
54 Posts
It could really be a whole lot of things. Fuel, air , electric.
Is there any engine codes?

No idea but start with the easy stuff. Check your air filter, take a plug out and see what it looks like. You can rent a fuel pressure tester from autozone and they give you your money back when you take it back so that's free.

If you put it in neutral and give it a touch of gas will it stay running or stall still?
 

·
Administrator
Joined
·
6,791 Posts
I assume you are not throwing a code, random stalling can be a sign of a TB going bad but not throwing a code due to the internal TB electronics.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #4 ·
It could really be a whole lot of things. Fuel, air , electric.
Is there any engine codes?

No idea but start with the easy stuff. Check your air filter, take a plug out and see what it looks like. You can rent a fuel pressure tester from autozone and they give you your money back when you take it back so that's free.

If you put it in neutral and give it a touch of gas will it stay running or stall still?
Only code I have is P0420 (still need to make up my mind on headers but I want something reliable that I can trust and actually gives at least a little more power). Might check fuel pressure this weekend. If I’m at a standstill in neutral or even just driving casually in town like I do on my commute, it doesn’t die (though my father has told me it has on him a few times). It’s only when putting it in neutral to coast after more spirited freeway driving at 4K and up.
 

·
Registered
Joined
·
5,829 Posts
I was going to say take a look at the tb for carbon build. Gotta relearn it if you mess with it
 

·
One of One???
Joined
·
1,514 Posts
Yeah tb go bad. I keep em around sometimes it's a voltage thing and they work on a different spec down the road.
 

·
Registered
04 spec v
Joined
·
54 Posts
I don't think it's going to be fuel pressure.
You need to chase that code down then probably put some new spark plugs in.
 

·
Registered
Joined
·
29 Posts
Try the crankshaft sensor, sounds like mine when the sensor was giving out.

I would be driving and all of a sudden, the rpms drop to 0 so I move it to neutral, give it a bit of gas before I go back into gear. Sometimes ( mainly on freeway) the car jolts hard like if I slammed the brakes. After the crankshaft sensor swap, all these problems went away. I had no CEL or any code pop up btw.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #11 ·
Try the crankshaft sensor, sounds like mine when the sensor was giving out.

I would be driving and all of a sudden, the rpms drop to 0 so I move it to neutral, give it a bit of gas before I go back into gear. Sometimes ( mainly on freeway) the car jolts hard like if I slammed the brakes. After the crankshaft sensor swap, all these problems went away. I had no CEL or any code pop up btw.
That’s the weird thing. It’s not while I’m gear. It’s stable in gear but if I’m driving it semi hard around 4K and then cruise in neutral (like slowing down to get into an exit), THAT is when the RPMs drop and it dies. It’s smooth too. It’s not an abrupt stalling.
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #12 ·
You have the original header still???
I’d get an eBay header to replace it but I don’t trust any of them. I want something that lasts the life of the car if I replace the stock one. I know I need it though. I’d get a 2J one but they all require messing with the radiator fan and brackets last I remember.
 

·
Registered
04 spec v
Joined
·
54 Posts
I'd probably yank off the factory header and knock the cat out of it then. At least when you take it off you can see if the cat was falling apart. Your code is all over a cat / oxygen sensor.
 

·
Registered
1995 Tercel - QR25DE
Joined
·
18 Posts
I have the 2.5 QR25DE in my Tercel, and after swapping i had the same issue doing a 178MPH Pull and i would clutch in and it would Stall and start back up without issues, it was MAF that was dead, and my AEM Filter was clogged, replaced both and never saw the issue,


AEM intake
and DXRacing 4-2-1 Headers

rest is "stock" - hope thie helps
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #16 ·
I have the 2.5 QR25DE in my Tercel, and after swapping i had the same issue doing a 178MPH Pull and i would clutch in and it would Stall and start back up without issues, it was MAF that was dead, and my AEM Filter was clogged, replaced both and never saw the issue,


AEM intake
and DXRacing 4-2-1 Headers

rest is "stock" - hope thie helps
You put a QR25 into a fucking Tercel???!!! That sounds fucking batshit lmao. Thanks btw. I might try cleaning my MAF sensor and stock filter if I can this weekend
 

·
Registered
1995 Tercel - QR25DE
Joined
·
18 Posts
You put a QR25 into a fucking Tercel???!!! That sounds fucking batshit lmao. Thanks btw. I might try cleaning my MAF sensor and stock filter if I can this weekend

Enjoy

Let us know if that fixed the issue :)
 
  • Like
Reactions: Tritton
1 - 17 of 17 Posts
Top