A Nissan Sentra Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, fellow Nissan owners and lovers! I just bought a 2006 Sentra SE R with 74K miles on it -- find of the last 3 decades IMHO! Always wanted one; finally got one! My first car ever was a 1990 Sentra and either myself or my kids have owned 3 more since. This one though is fire! But, it's throwing a P0850 code and I don't know what the actual diagnosis is and I can't find very much info on it. My investigation has turned up a Park/Neutral switch, but this car is a 6spd manual and most forums indicate that this code is for an automatic tranny. I fell in love with this car the first time I saw it and I wanna give it more TLC. The correct diagnosis and fix would be a great start!
 

·
Super Moderator
Joined
·
6,206 Posts
Pull the ecu out and let us know what sticker/ part number is on it.
 
  • Like
Reactions: wahshow

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I was able to figure out what the issue was: the wiring harness to the Park/Neutral switch was not attached. The plastic housing for the connectors was damaged. It looked like it was forcefully pulled off of the switch. I went to the junkyard, cut off the wiring harness and housing for this component from an '05 manual Sentra, and spliced it into my wiring harness. I've plugged it back in and after 100mi, the CEL is no longer on. Time to move on to bigger and better things, like rebuilding the entire front end steering components.
 
1 - 4 of 4 Posts
Top