A Nissan Sentra Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi guys, kinda new to this, I got my 05 specv with around 83,000 miles and about a month ago the steering wheel started to shake more around 70-80 mph, only randomly, and now about a week ago it sounds like the engine is misfiring randomly too. When it does front (passanger side) of the engine shakes hard the pulles sometimes quiky when its shaking. I have checked the spark plugs and coils but cant find anything to indicate a cause. The engine is basically stock so idk where to check now.
 

·
Super Moderator
Joined
·
5,309 Posts
Did you check if the are codes at all, you may have pending codes, pending codes don't trigger a check light.?
 

·
Registered
Joined
·
4,906 Posts
If there is a loss in power it's a coil. For some reason the cel takes a lifetime to come on. I feel like it's something in the front end at that speed. Too high for tire balancing.
Motor mounts seem hard to believe at a cruise speed at 2800rpm.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
If there is a loss in power it's a coil. For some reason the cel takes a lifetime to come on. I feel like it's something in the front end at that speed. Too high for tire balancing.
Motor mounts seem hard to believe at a cruise speed at 2800rpm.
Yeah, I was thinking one of the coils too. The sparkplugs and serpentine belt are under 5k miles. Also, the car worls perfect about 30% the time but when it doesnt my cat ideals around 900rpm and when its really bad the engine bay will sputter and squeek
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Solved: It was 2 of the coil packs. Just put one in whatever coil, misfires were rapid and codes finally showed, got p0301 and p0303. Ran better than before after the swap. Amazon has oem coils for cheapER if you know the part number.
 
1 - 8 of 8 Posts
Top