A Nissan Sentra Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hey guys, so I got the p0420 code recently and decided I would take my cat apart and clean it of its material. So I went through the trouble of taking off the exhause manifold and everything that goes along with it just to find out it had already been gutted. So whatever i put it all back together, and I went ahead and did the poor man spark plug anti fouler mod for the 02 sensor. Car runs fine and everything now but it's starting with a sputter like it wants to die and sometimes it does die other times it pulls through. I'm thinking maybe I didn't drill the hole for the 02 sensor wide enough. If you guys have any ideas help is appreciated.
 

·
Super Moderator
Joined
·
5,332 Posts
The spacer needs to be post cat, the pre cat sensor is what is reading the air/ fuel and that's why it running the way it is.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
Ok so for anyone who might be interested and wants to read how this was resolved, it was really strange but it might help someone so here goes. I got a p0420 code, after taking apart my exhaust manifold and alternator I cleaned up my engine bay, with some degreaser and put everything back together with an o2 sensor spacer (anti fouler) on the pre cat. Car started right up, no codes, ran perfect. Next day on my way to work I get a code for the camshaft sensor, can't remember the #... but it was there nonetheless. I though it was weird only thing different was the o2 sensor spacer. So I take my o2 sensor spacer off and put it back without it. Drove the car about 45 miles or so and wouldn't you know it the code went off. I checked the wiring on my camshaft position sensor and it all checked out. If I ever figure out what it was I will post.
 
1 - 7 of 7 Posts
Top