A Nissan Sentra Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Ive seen the other posts in the forum about rev issues, but I havent seen any. hat are about my car so here is my question.
I have an 06 Sentra with a vq35de swap done by travis, not trying to blame him or anything im just stating. One day I was driving along and my car stopped being able to rev past 2500 rpms. It will just bounce there. My car isnt idling rough or even trying to kill itself. But I realized that if I delete the codes it throwing, which are very random sometimes ill have 4 codes sometimes ill have 11, but thats besides thw point I guess, once I delete the codes the car will drive fine. So I am just trying to find out how to get rid of this whole deleting codes before driving anywhere issue. Im sure where to start.
Thanks.
 

·
Premium Member
Joined
·
39,110 Posts
Instead of deleting the codes, fix what the codes are trying to tell you what is wrong.
 

·
Premium Member
Joined
·
39,110 Posts
Its different codes everytime
You could try to fix the easy ones like buying o2 sensors.

If you buy new sensors and the code comes back, then your ecu might be crapping out.
 

·
Premium Member
Joined
·
39,110 Posts
What ecu are you using?
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #9 ·
See I wanna try the ecu first because I think that is the issue. But idk lol I don't want to spend a lot of money amd then I be a silly problem like just the ecu
 

·
Premium Member
Joined
·
39,110 Posts
That is why I said o2 sensors, they are cheap, therefore a cheap fix.

Only ballers find ecu issues to be cheap...:troll:

If you have another ecu that you can borrow, then borrow it and see if you are getting the same issues.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #12 ·
So yall think the eecu would fix the rev issue? Im only focusing on it so much because the motor over heated once. And im thinking it fried the ecu..
 

·
Registered
Joined
·
19,790 Posts
i'm going to start slow

1st is it a new series swap
, nylatron motor mts, unequal y pipe, obx shorty headers, clamped not soldered harness connections, and 02 ECU and matching MAF in basic form [non- inspectable]
this is what i had

11 codes are normal with cams mine had 26 [mostly duplicates , many are from the mismatched ECU]

try changing the MAF
i went thru 3 of them in less than a year
make sure you have good grounds on the electronics and battery

while your there, is the alternator is putting out proper voltage,

and that all the harness connections are intact
 

·
Premium Member
Joined
·
39,110 Posts

·
Premium Member
Joined
·
39,110 Posts
1 - 20 of 22 Posts
Top