A Nissan Sentra Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
170 Posts
Discussion Starter #1
I got two requests for stuff associated to the emanage ultimate so I decided I would post it up.

There are three files attached.

EU install help.pdf is a pdf I made illustrating how I installed the EU and the little tricks I used to get it to work the way I wanted. ie. adding a knock sensor, outputing to a led if the knock went too hig. etc.

kyle diagram.pdf is a pdf I made for an old schooler showing him hopw I set up a quick disconnect. I put a male female plug in the middle of all connections going to the EMU so if i needed to disconnect it and go back to the "stock" wiring/ecu connections, I could.

The last file Curent +6 above 11.6psi 12_10_09.pdf IT IS NOT A PDF. I had to upload it this way because the uploader would not take it as an EM2 extension.
Take off the extension (pdf) and put on EM2. It is an actual tune for my car before I went over to Osiris. It should be tuned up to 15-20 psi. If you are running a 02-03 MAF clear out the "airflow adjustment map". I tuned based on PSI which worked best for me. You need a boost sensor for this to work so if you want to tune by another method you are SOL.
Injector latency is based on modded stockers. The O2 sensors were not attached. But I think the baseline of the injectors are close enough that the tune would not drift if they were.
IF YOU BREAK YOUR CAR USING THIS MAP I AM NOT RESPONSIBLE.

Here are the car's specs associated with the MAP
Modded Stockers (static pressure 60psi)
T3/t4 .60/.63
04+MAF
8.5:1 Compression pistons
3"exhaust
 

·
Registered
Joined
·
23 Posts
Thanks Pregunta

I am setting my eManager but I wonder if you can help me with some doubts I have.

Greddy not fix the error of the knock sensor in its latest firmware?

Because you set the minimum manual throttle?

In idle knock voltage is 2.5v but when motor have detonation what is LOG voltage shows?

In the vehicle configuration setup 2700cc, this is for low compression pistons?

I want to continue with the O2 sensor connected, the signal of O2 sensor connect to pin 31 analog and increase the voltage for the analog output EU to ensure that the ECU and the engine will not run rich at idle and low load to improve the gas mileage (closed loop).

But when turbo boost generates I use a relay connected to pin 43 or 44 (using map) to disconnect the O2 sensor signal and go into open loop and use my Innovate wideband to autotune the injection map 1.

I have only a problem when I put neutral and brake slows the RPM down to 900 but up to 1100 without depressing the accelerator and then down to 850 idle.

Sorry for my bad English Thanks
 

·
Registered
Joined
·
170 Posts
Discussion Starter #7
Greddy not fix the error of the knock sensor in its latest firmware?

In idle knock voltage is 2.5v but when motor have detonation what is LOG voltage shows?v
When I was using the EMU greddy had never really fixed the knock sensor issues. I don't know if they have come out with newer firmwares since then. To use the knock sensor, I "t'"-ed into the voltage side of the knock sensor and sent that signal into the EMU (analog input). The solid 2.5v input means no knock when the voltage jumps up OR down I took that as an indication of knock.

In the vehicle configuration setup 2700cc, this is for low compression pistons?
I have the vehicle setup at 2700cc because my engine is bored out to 2700cc.

Because you set the minimum manual throttle?
It may have just been in my mind but it helped with some of the on/of throttle issues I was having.

I want to continue with the O2 sensor connected, the signal of O2 sensor connect to pin 31 analog and increase the voltage for the analog output EU to ensure that the ECU and the engine will not run rich at idle and low load to improve the gas mileage (closed loop).


But when turbo boost generates I use a relay connected to pin 43 or 44 (using map) to disconnect the O2 sensor signal and go into open loop and use my Innovate wideband to autotune the injection map 1.


I have only a problem when I put neutral and brake slows the RPM down to 900 but up to 1100 without depressing the accelerator and then down to 850 idle.


Your injector fix is really good, I like it. Give this a try, but it may reqiure you to do a slight retune. Disconnect both O2 sensors and clear the long term fuel trims. Using the MAF voltage out map try to get the car to idle at 14.7. You want to keep the MAF voltag goin to the ECU within a certain spec thou so keep an eye on that in the logs.
Once you get the car idling at 14.7 reconnect the O2 sensors. If your injectors are larger than 440cc than this may no work.

Using this and the injector resizer in the car setup map, you are tricking the ECU to thinking there are no adjustments necessary to get the car to idle at the correct AFR's.

I am not sure how well it is working for you but I noticed that when I disconnect my O2 sensors it takes a while for the ECU to stop trying to control fuel and settle into the base fuel map.

Depending on how big the injectors are that you are using this may help the idle jump coming to a stop. My car does it also, it is one of two things the air flow to the MAF is taking a while to stablize because of the size/type of turbos we are using of the ECU is having a hard time controling the size injectors you have in the car.

Let me know if this helps.
 

·
Registered
Joined
·
3,980 Posts
for people wiring this up and where you have to cut the wire it is ecu->x,y->senor/inj/ign
 

·
Registered
Joined
·
194 Posts
Anybody have this currently or recently in their car? And what's the situation with a diode needed. Is there an actual model number of the diode needed?
 
1 - 10 of 10 Posts
Top