A Nissan Sentra Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
So i have 2 HID Kits installed for my headlights with 10000k Bulbs installed.

My problem with them is that they are not bright enough as they should be and they are not the color they should be either. They are supposed to be a bluish color. But they turn really white and are not bright at all. I can barley see at night.

Whenever i first turn my car on and turn the headlights on they will start and turn blue and bright like they should but after about a minute they are white. The bulbs are not old at all maybe 3 months.

Right when i turn my car on sometimes I will hire a little buzzing noice that will last like 5 seconds and seems that comes from the Fuse box of my car but i am not sure. I dont why this has to do with the kit because it is connected to the battery. i also have subs and amp to the battery along the kit for my fogs..

The kit came with a relay wire but i did not use it. I also have 3000k yellow fog lights and those are not a problem at all and i do have the relay installed. They are the same kit as the fogs.

Carid is sending me new ones and i returned these bulbs as well. I do not think the actual bulbs are the problem tho i will have to find out...


anyone have any suggestions please and thank you!!! apreciate it
 

·
Registered
Joined
·
9,641 Posts
Well to begin, you should hardly be able to see with 10k bulbs... You start to lose visibility after 6k "they" say. 4300k is optimal temp. for best visibility.
If visibility is what you want, get 6k for the hint of blue. If looks is what you want, don't complain then. Lol.

As far as them being white in color. Idk. Is this a real HID kit, or just some "HID bulbs" ?

The noise you hear is normal, it's coming from the ballasts, which would mean you got a real HID kit I guess.

Also, where did you get these?



 

·
Registered
Joined
·
137 Posts
10k should be pink if i recall, my DDMs are 5 or 6k and are white with a slight blue tint

Use the relay though, no sense putting all the strain on your existing wiring and factory fuses

Sent from my DROID RAZR using Tapatalk
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
Well to begin, you should hardly be able to see with 10k bulbs... You start to lose visibility after 6k "they" say. 4300k is optimal temp. for best visibility.
If visibility is what you want, get 6k for the hint of blue. If looks is what you want, don't complain then. Lol.

As far as them being white in color. Idk. Is this a real HID kit, or just some "HID bulbs" ?

The noise you hear is normal, it's coming from the ballasts, which would mean you got a real HID kit I guess.

Also, where did you get these?
I know what you mean about the visibility but I look at other cars with 10000k bulbs and theirs look the color it should be and far way more brighter.
They are a real hid kit I bought them from carid.com

The noice didnt seem to come from the ballast but in my car on the driver side and then my right headlight went out lol but I fixed it
 

·
Registered
Joined
·
261 Posts
10ks are usually real blue and 6k is white 12k is pink but the colors can vary between companies but from what he is describing it sounds like your balasts are bad i have run into this before on a customers vehicle that we installed HIDs on and we swapped out the ballasts and havent had a problem since
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top