A Nissan Sentra Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
3,610 Posts
Discussion Starter · #1 ·
hey guys I am making this thread for one of the boosted spec v in phoenix.

He needs a start to finish on how to rewire the fuel pump for better voltage????

if anyone can help that would help him greatly!
 

·
Registered
Joined
·
944 Posts
For better voltage? What does that mean? :thinking:
The flow of a fuel pump is directly related to voltage. A walbro with ~11.5-12v will flow less than one with a rewired pump getting 13v.
 
  • Like
Reactions: MoltenNismo

·
Registered
Joined
·
3,070 Posts

·
Registered
Joined
·
3,070 Posts
In a nutshell you can take the factory wire that powers the fuel pump and run that to pin 85 on a relay.
Run pin 86 to a good ground.
Run a power wire straight from the battery to pin 30
And run pin 87 to the connector side of the fuel pump.
Boom. Straight battery/charging voltage to the pump

But I would still recommend the boost a pump if he actually needs this. It'll bring it up to 17volts
 

·
Registered
Joined
·
3,070 Posts
Few things to check. If you're on e85 make sure you're using the walbro 400 that's intended for e85 which I think u already said u were. Secondly I'm at 400whp on a return single walbro 255 with no fuel issues. Make sure there's not a bad filter or maybe even just the pump itself is bad. And lastly walbros are notorious for dropping pressure after 80psi. I know there's a mod for the 255s I'd think u could do the same on the 400 but there's a plug that u push in with a punch to keep the relief valve from bleeding off (may just be an Evo thing now that I think about it)
But long story short, a properly set up 400 pump should be more than enough for 450whp. Check elsewhere.
 

·
Registered
Joined
·
3,379 Posts
He has the stm fuel pump rewire kit. The fuel issues were with the 255lph whalbro. Now were gonna switch out to the 400lph e85 fuel.
The rewire kit is to make sure he has enough voltage.

What I/ we need. Is the wiring diagram for the pump. The power and signal wire so I can wire it properly. I checked the fsm but couldn't find it (only did a quick search) and are the wires the same for 02-03 and 04-06.
Gonna rewire his and mine same day.

Thanks fellas!
 

·
Super Moderator
Joined
·
6,872 Posts
It's under EC. All the way to the bottom. You'll see it Corn. Also it's all the same for the years.

Black/red goes from the FP fuse to the control side of the FP relay.
Black/white goes from the FP fuse to the supply side of the FP relay.
Black/purple goes from the ECU to ground the fuel pump relay.
Black/yellow goes from the supply side of the FP relay to the pump. (Pin # 1 from the pump connector)
Black is ground for the pump. (pin# 3 from the pump connector)
 

·
Registered
Joined
·
382 Posts
Revive!! Figured i could post my experience and what i learned. I have an 05 SER but its 6spd with changed ecu with nats and wiring harness,(if that matters) well, first i spliced the oem pump wires that were thicker which were blk/yell and blk, my guess those were power and ground due to thickness, but nope, in reality it was orange and green�� the thinnest, which is wierd cause i went to the pump relay at the driver side lower panel and tested the circuit which the blk and yellow had power but not at the pump, at this point im confused still and my pump now works.....success��
 
1 - 20 of 29 Posts
Top