A Nissan Sentra Forum banner
1 - 20 of 51 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hey everyone! I got it back In June and have been slowly working on it but realized a few days ago the maf sensor screws are stripped and figured I'd mention that while saying hello just in case anyone knows how to remove them (tried searching and only seen MAF sensor problems and not with stripped screws)
 

·
Super Moderator
Joined
·
6,510 Posts
What year, if it's an 00 to 03 i have a complete maf assembly laying around I have no use for, but with out looking i believe it's a torx bit but don't remember if it's security or not.
 

·
Moderator
Joined
·
6,866 Posts
Are the screw threads in the housing messed up that the MAF is lose in its housing or it's stripped that you couldn't remove it? You can always use a small vice grips just to remove them if it's the latter.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 · (Edited)
Stripped that I couldn't remove it because I think I have a failing fuel pump and was trying to get to the MAF sensor to clean it just in case (car started acting up when I got to quarter of a tank and I couldn't accelerate going uphill or taking turns and then it would eventually go) I also had a warm start issue but I cleaned out the throttle body with some spray and that seems to mostly have fixed that.. Other then that I was thinking of running seafoam or Chevron through it also

Edit: Oh yeah when I put in over half a tank of gas yesterday it seemed to act better but didn't drive over any hills

Edit 2: also bogs while accelerating if I actually try pressing more then usual on the gas which I am assuming is fuel pump
 

·
Registered
Joined
·
2,027 Posts
Post a pic. It is a torx screw #20 some people say #25 or #27. But i literally replaced mine 2 weeks ago
And its a #20 torx screw. You can probably put a screwhead socket over it and turn to unscrew it. But like the other dude said you can probably replace the whole maf unit housing to make it easier. And this is a good example to use the right tools. These cars are brittle this late
 

·
Registered
Joined
·
2,027 Posts
Stripped that I couldn't remove it because I think I have a failing fuel pump and was trying to get to the MAF sensor to clean it just in case (car started acting up when I got to quarter of a tank and I couldn't accelerate going uphill or taking turns and then it would eventually go) I also had a warm start issue but I cleaned out the throttle body with some spray and that seems to mostly have fixed that.. Other then that I was thinking of running seafoam or Chevron through it also

Edit: Oh yeah when I put in over half a tank of gas yesterday it seemed to act better but didn't drive over any hills

Edit 2: also bogs while accelerating if I actually try pressing more then usual on the gas which I am assuming is fuel pump
It probably is a combination of both. Replace mafs with oem no Amazon. And the fuel pump might be going out too. When you clean the throttlebody you should be meticulous and do throttlebody relearn. Im not sure if it applies to GXE tho. I can imagine its a high mileage GXE so things are needing replacement
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #8 ·
It's got about.. 93 or 94k on it right now, but I kinda assumed getting towards 100k it def needs new plugs n what not. (I have coils and have to wait till Friday to get spark plugs) I'm just not sure where I will be getting a fuel pump from... Yet. oh! and will take a pic soon
 

·
Registered
Joined
·
2,027 Posts
Bro. Just replace the maf housing w maf installed ..It comes with the maf already installed. If u can get a small socket over the stripped screw and unfastened that way .. ok. But if it were me. Id just replace the whole maf housing w maf installed. And id replace the bolts too. This shit will take 5 mins to disassemble, and 10 mins to put back. 30 if your like me id clean and replaced that rusted bolt
 

Attachments

·
Registered
Joined
·
33 Posts
Discussion Starter · #11 ·
I might just take that route and yeah I gotta get that rusted screw off and just put a new clamp on in it's place thanks I'll update once everything's done
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #13 ·
Also I tried searching "torque specs Spark plus" and can't seem to find the answer... Should I not be too crazy about getting it perfect? Sorry for all the questions!
 

·
Super Moderator
Joined
·
6,510 Posts
  • Like
Reactions: iicbh

·
Registered
Joined
·
33 Posts
Discussion Starter · #15 ·
Warm start problem started to intermittently come back so I'm hoping the Bosch pump corrects everything since I now assume/think it's all the pump now which I should get tomorrow!
 

·
Registered
Joined
·
2,027 Posts
Also I tried searching "torque specs Spark plus" and can't seem to find the answer... Should I not be too crazy about getting it perfect? Sorry for all the questions!
Bruh, just go to Vatozone and Orileys and get whatever premium plug they got. It usually has a mail in rebate if ur lucky.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #17 ·
I'm getting the ruthenium ones but I meant what I should torque them at or if I should not be to worried about that part sorry!
 

·
Super Moderator
Joined
·
6,510 Posts
Torque value is low, might have a torque value on the box. I never torque the plugs to spec.
 
  • Like
Reactions: Tritton

·
Registered
Joined
·
2,027 Posts
I'm getting the ruthenium ones but I meant what I should torque them at or if I should not be to worried about that part sorry!
I never really torque them. I've changed my plugs 3 times. Dont over tighten it. A good solid turn once its seated is good. Also make sure to use that plug grease on the threads of the plug. Ask the car parts tech. They have em at the register for a some change. But you can torque them, im not sure what the poundage is tho.
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #20 ·
Welp I've got a completely new problem... My negative terminal snapped in half and my car is stuck at work....Dare I ask for a suggestion replacement? I'm not sure I wanna get another AutoZone one...I barely got that one a month or so ago and and confused how it happened >.>

Edit: still gotta clean engine bay but was trying to get everything straightened out first

 
1 - 20 of 51 Posts
Top