A Nissan Sentra Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter #1
Everytime I start the car it takes about 3 seconds of cranking for it to start up and code p0335 comes up. I drive 100 miles a day to work and back with 32mpg on the dash. It does feel sluggish when going up a hill underload, when I step on the gas to accelerate it doesn't really speed up and it starts smelling like the engine is getting hot. But not over heating. Other than that the car runs fine. Today code p0011 also came up at start up I keep checking the codes when I start the car just in case something else pops up, and it did.
All this started happening after replacing my head gasket had the timing wrong wouldn't start, redid the timing got it right and now the code. I replaced the cam and crank sensors twice with the lifetime warranty I have on them. I replaced the connector on the cam sensor because the wires were exposed. and the crank sensor wires look like new, so did nothing to that. Last year I rebuilt the engine with high compression pistons and a knife edged crank. Also got a new timing chain. Need help figuring what causes the slow start and that crank sensor code.
 

·
Registered
Joined
·
27 Posts
The hard starting, have you replaced the starter?
The p0335, never had that happened to me but is the battery healthy or are there any exposed connections? Since you did replace the sensors.
 

·
Super Moderator
Joined
·
5,225 Posts
These codes look to effect each other.

0335 is your crank sensor, 0011 is to your IVT controller, 0335 may be causing 0011 since the signal from the crank(and cam) dictates the operation of the IVT solenoid
 

·
Registered
Joined
·
27 Posts
Got this code today. Yesterday seemed like the car bigger and rpm went to 0 for about 2seconds. I cleared the code to see if it will happen again. This is after swapping nismo header to OEM hollowed out one it had for snogging purposes.
 
1 - 4 of 4 Posts
Top