A Nissan Sentra Forum banner

41 - 48 of 48 Posts

·
Registered
Joined
·
368 Posts
No further info needed. I literally could not have given more info on how to properly trouble shoot the tits off this thing.
Alright, continuity is there. Tested valve and it works. Have voltage at the connector. What's next on my to do list ?
 

·
Registered
Joined
·
1,993 Posts
I can add that I had that code once and it turned out to be the inside of the solonoid was rusted. I tossed it into a cup of pb blaster for a day and then got it freed up bench tested it with 12v and blowing through it reinstalled it and worked ever since. This is common problem for many cars.
 

·
Registered
Joined
·
368 Posts
uploadfromtaptalk1457842363648.jpg found this cracked house going into the evap canister. I had never bothered to look even tho I knew this part of the car had something to do with the purge valve
 

·
Registered
Joined
·
4,006 Posts
Discussion Starter · #47 ·
Well guys, after all this time we have finally fixed the issue causing the P0444 code.

Thanks to Diego I also checked the hoses leading to the evap canisters and there she was, the thickest hose had cracks! Replaced it and so far no more codes, guess I'll be missing that yellow SES light.

Big Thanks and shout out to everyone who has helped out on this thread!
 

·
Registered
Joined
·
1 Posts
No further info needed. I literally could not have given more info on how to properly trouble shoot the tits off this thing.
I am rebuilding a 2003 sentra. The list of parts already put on is long and all i have left is this code with a sweet spot in the gas pedal and stall trying to go up hills. Any help is welcom.
 
41 - 48 of 48 Posts
Top