A Nissan Sentra Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
So I recently Treadstone performance turbocharged my car and it's throwing a p0507 High Idle and I've put quite the effort to solve it and am having no luck. I'd appreciate any ideas.

Before anyone asks, I've searched for solutions to fixing this problem, example idle relearn, checking for vacuum leaks [I even took it to a shop and paid to have a vacuum and compression check done]. Some Details: The car has a small exhaust leak at the wastegate and vacuum on the boost gauge reads 21 in-hg. The car has the base tune I got from treadstone since they dont include the unichips with the 04-06 kits anymore. Overall the car runs all right under boost (wot afr :10.8) but then it idles it revs itself between 1200~2000rpm. I'd appreciate any help. Thanks.:)
 

·
Registered
Joined
·
9,641 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
I've cleaned the maf and checked for vacuum leaks. Though oh3_specv I haven't tried messing with the bov's setpoint. I'm guessing that's what the metal spring is for? Thanks for the quick response.
 

·
Registered
Joined
·
646 Posts
i had the turbonetics kit and was running the raptor bov and kept stalling on me. messed with that top adjustment screw and helped a good bit. then i switched to a cheap bov i got from a friend and runs perfect after adjusting the bov
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #6 ·
So I adjusted the bolt on the top of the BOV and it didn't do anything. The car surges between 1500~2000rpm and i noticed when I turn on the AC on max it idles stable at 1250rpm. I have the tuner version of Uprev's software, and I was wondering if it's only a tune issue?
 

·
Registered
Joined
·
738 Posts
need to go to nissan and have them do an idle relearn with the consultII, and do not leave the dealership until they do it and it works, and don't pay a fucking dime for it.

and don' let them bullshit you. every car will take an idle relearn. i've had dealerships tell me that my car won't take an idle relearn via a consultII, but i picked the consult up and tried it a few more times and bam, it took. looks like it's an average of 3-5 times for it to take, and sorry, but the pedal dance just won't cut it when it comes to this. if you're lucky, it'll work for a little bit, if at all.

consultII my friend. that's what you need. or one of those sweet new consultIII.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #9 ·
So I took the car to the dealership today and asked the car service guys to do an idle relearn and after 40 minutes he came back telling me that my throttle body was toast. I asked him what was wrong with the throttle body like if he ran any diagnostics on the throttle body [check voltage against mechanical position] or idle sensor and he just kept telling me just to buy their refurbished throttle body for $825. Walked out of the dealership and now the car idles worse [1800~3k rpm]. If anyone has any ideas I'm open ears and if not, guess I'll be rush ordering another one. :dunno:
 

·
Registered
Joined
·
232 Posts
It needs an idle relearn.

Do the pedal dance, or take it to another dealership with someone who has half a brain.

Most Nissan mechanics are just part replacement technicians. Instead of diagnosing a fault, they just throw new parts at cars.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #11 ·
Update. So I bought a new throttle body just in case. The old throttle body read different voltage between the two TPS (Around 0.2V which is a lot on a 5V scale). Installed the new throttle body and preformed relearn and to my surprise nothing happened. I've read the FSM and I don't see what Im possibly doing wrong for the pedal dance so if anyone can correct me I'd greatly appreciate it.

Procedure (Done with a stop watch)

Drive car for about 10 minutes.
Ensure Engine Temp is NOT.
Ensure Transmission is warmed.
Ensure car is in neutral, parking brake engaged.
Wheels straight.
Batt volt atleast 12.9V
All accessories de-energized (headlights, a/c, etc)

The "on" position is the last position (4) On
The "off" position is the first position after lock (1)

Perform pedal and throttle relearn.
Pedal.
Perform step x3
On for 2 sec
Off for 10sec
Throttle
place car in 1st gear
On for 1 sharp second
Off for 10, confirm operating sound. (by fully depressing and fully releasing accelerator pedal) I haven't ever heard anything, but w/e.

Relearn idle
Off for 10sec
On for 3 Sec
Pedal fully depressed and released 5x within 5 seconds
Wait 7
(If done by timely, should be at 25 seconds)
Depress pedal for 20 sec and release or wait till SES light goes solid. Release pedal within 3 sec, start car and let idle for atleast 20sec.

Thank you.
 
1 - 18 of 18 Posts
Top