A Nissan Sentra Forum banner
1 - 20 of 21 Posts

·
Baby Kicker
Joined
·
4,437 Posts
Discussion Starter · #1 ·
so lately i have been having problems with the spec. Every now and then the idle goes wild and the check engine light goes on. Like today i started up the car and the idle was on like 1500-2000 rpms. When i revved it slowly went up to 2000k like it was on limp mode.Icertain it might be the TPS(throttle position sensor) Would getting a new TB fix the problem? It def. is the TB and i dont have anything else wrong with the car. I need to scan this damn code but i never have time and erase it.

What do you guys think?

Oh and also, my cooland seems to be leaking. I had a full resivoir and now its on minimum. I see a lot of splatters around the radiator, so could it be leaking from the top of the radiator from the knob? Also the cap on the radiator is splitting, where can i get another one?
 

·
Registered
Joined
·
785 Posts
Matt, just go to Autozone for them to read and delete the code. If its the anything to do with the TPS it may be the sensor itself as opposed to the TB.

Get a radiator cap from ebay.
 

·
Baby Kicker
Joined
·
4,437 Posts
Discussion Starter · #3 ·
what about the cap on the resivoir, the plastic box holding the rest of the coolant?

also i dont have an autozone around here, so i have to go all the way to richmond hill.
 

·
Registered
Joined
·
2,290 Posts
Matt it can be the tps, same thing is happening to me. As for a reader, i still dont have mine, my friend still has it. Id help you out but i cant seem to reach him right now.

For the coolant shit, just go to a auto store and pick up the resevoir and cap, should be cheap.
 

·
Registered
Joined
·
2,290 Posts
Also, for the radiator shit.

Do you check the coolant afte ryou drive?

Because with my car recently its been over heating. So when i drive and look at my coolant its really low, but when i let it cool down, all the coolant comes back. If your having the same problem, you might need to put some coolant and water in your radiator it self. And your coolant level and shit should be fine.
 
G

·
damn.......2.5 engine keeps having problems, im glad the 2.0 engine doesnt give problems , i keep readin about 2.5 defects and the recalls, even korean cars like kia and hyundai dont got that much problems.
 
G

·
matt is that the only thing in limp mode???

:jerk:

check the connections to the radiator, maybe one of the rubber hoses sprung a leak. so you dont have a cap on the overflow bottle? you could easily get a rubber band and a piece of a plastic shopping bag and ghetto fix it.

as for the limp mode- are you sure your maf isnt messed up? for the most part from what ive seen on the forums people that have that limp mode crap usually have to replace their maf's
 

·
Baby Kicker
Joined
·
4,437 Posts
Discussion Starter · #17 ·
Fock you, Fock you all lmao....im kinda pissed today..focken birthday sucks so far..

the only 2.0 that i want is the evolution, thanks...

my cock is rock hard feroze, come check it out lol...as far as the maf, ill check it out...i need that damn code read.
 

·
Baby Kicker
Joined
·
4,437 Posts
Discussion Starter · #19 ·
a lil update...when i got the work i unplugged the tb sensor, now when i came back i started up the car and totally forgot about it...guess what same symptoms that i had this morning. The thing is i had this sticky substance(lol) on the inside of the connector. Maybe that was interefering with the connections and thats why i was getting the code. So now i got the code again and ill scan it later and we'll see what it is, if thats the problems, at home i have a electric connection cleaner so ill just spray some of that
 

·
Registered
Joined
·
692 Posts
Matts Spec V said:
a lil update...when i got the work i unplugged the tb sensor, now when i came back i started up the car and totally forgot about it...guess what same symptoms that i had this morning. The thing is i had this sticky substance(lol) on the inside of the connector. Maybe that was interefering with the connections and thats why i was getting the code. So now i got the code again and ill scan it later and we'll see what it is, if thats the problems, at home i have a electric connection cleaner so ill just spray some of that
i got the contact cleaner at my house when u meet jon let him gimmie a call and i'll pass by with it...
 
1 - 20 of 21 Posts
Top