A Nissan Sentra Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hello all! I bought a 2006 Spec V last thursday. They guy I bought it from threw in some parts he had including a NISMO CAI. I had some spare time this weekend so I removed the factory air box and installed the CAI. While I was performing the install, I noticed some carbon build up on the throttle body. I cleaned it, continued the install, and reset the ECU via the negative battery cable. When I went for a test drive, the car performed very well except for it would now hang at about 1500 rpms with a clutch push. I've noticed that is a common problem especially after resetting the ECU and/or cleaning the throttle body. I've found several posts about how to relearn the TPS by doing the on, off, on, 5 gas presses, etc... but I could never get the "Service Engine Soon" light to blink. I found some other articles that said to unplug the Mass Airflow sensor and replug. Didnt work. Even saw an article saying to unplug the TPS and replug. That didnt fix it either. All I've managed to do is throw codes. Any other suggestions? I've heard I can ask the dealer to reset this...anyone know how much that costs? Any help is greatly appreciated.

Also, while installing the CAI, I noticed a small hose coming from the transmission thats not hooked up. It wasn't hooked to anything on the stock air intake either. I'm not sure where it goes. Anyone know what this could be or where it should plug in?

Thanks,

Joe:thinking:
 

·
Registered
Joined
·
1,681 Posts
AHHH shit are you the second owner or first??? coming from the trans hmm yes very common problem you can fix this issue hmmm let me see mmmm that is supposed to be hooked up to the back of the block!!!!:eek:
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #4 ·
I have a new header and midpipe going on soon. I've tried the steps in that video all afternoon. No dice. The engine light comes on as soon the key is turn on, it never blinks. I havent cleared the codes yet, that may be the hold up...but i dont have a scanner.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
AHHH shit are you the second owner or first??? coming from the trans hmm yes very common problem you can fix this issue hmmm let me see mmmm that is supposed to be hooked up to the back of the block!!!!:eek:
I'm obviously not the original owner since I said I bought the car last thursday and its a 2006...
 

·
Registered
Joined
·
2,442 Posts
The tranny hoses is a breathe hose. You can leave it as it.
1. Perform ACCERLEARATOR PEDAL RELEASED POSTIONS LEARNING
2. Perform THROTTLE VALVE CLOSED POSITION LEARNING
3. Start engine and warm it up to operation temperature
4. Turn igniton switch OFF and wait at least 10 seconds
5. Confirm Gas Pedal if fully realeased, then turn igniton switch ON and wait 3 seconds
6. Fully step on and release gas pedal 5 time within 5 seconds
8. Wait 7 seconds and fully step on gas and stay on until MIL stops blinking and is steady.
9. Fully release the Gas pedal within 3 seconds after the MIL has turned ON steady.
10. Start engine imediatly and let idle. Wait 20 seconds.
Keep trying LOL you'll get it some day. Get a timer/stop watch or something.
Step fast 5 times.
 

·
Registered
Joined
·
57 Posts
I have the same kind of problem when I am running my SRI. It idles at about 1500rpms. I did the peddle dance and unplug/replug the Tb and it still didnt work. It started to happend after cleaning the Tb. I then put the stock intake in and drove it for bout a week and it went away but comes back every so often only if Im running the SRI..However my car dies when Im stopping at a light when using the CAI.If anyone knows about the dieing issue let me nkow..Hopes that helps Buddy...
 

·
Registered
Joined
·
1,222 Posts
You are doing the pedal dance wrong. I hope you didn't try to clean the maf sensor. Disconnect the battery for 30 minutes to an hour. After you reconnect the battery let the car ideal until the rpms come back down to 800ish, this could take ten minutes. Don't immediately rev the piss out of it wait until it ideals correctly. Hope this helps good luck and welcome:wave:
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #10 ·
You are doing the pedal dance wrong. I hope you didn't try to clean the maf sensor. Disconnect the battery for 30 minutes to an hour. After you reconnect the battery let the car ideal until the rpms come back down to 800ish, this could take ten minutes. Don't immediately rev the piss out of it wait until it ideals correctly. Hope this helps good luck and welcome:wave:
I didnt try to clean the MAF sensor. I'll try this when I get home today. Thanks!
 

·
Registered
Joined
·
2,442 Posts
Lmao, he said he hopes you didn't try to clean the MAF.
Usually that means you shouldn't clean it.

Check for leaks n idle relearn
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #12 ·
Lmao, he said he hopes you didn't try to clean the MAF.
Usually that means you shouldn't clean it.

Check for leaks n idle relearn
I know that! I meant I'll try to disconnect the battery for an hour and reconnect, crank, and let idle... :47:
 
  • Like
Reactions: frozenbarb

·
Banned
Joined
·
904 Posts
disconnect the battery for 30 minutes like noted above , check for uncleared codes even if you dont have the check engine light on,

honestly though seems like you just need a relearn and your doing it wrong it took me forever to get it down right lol
 

·
Registered
Joined
·
1,114 Posts
I've cleaned my TB a few times, the re-learn always worked. The last time however, it did not. Some how my TB "lost communication (all the tech said)" and would not re-learn, it free revved from 1500-2000 RPM and just could not find an idle.

The techs had to reset it with Consult II. The tech mentioned that the TB of course needs to re-learn idle every time it is unplugged and cleaned but he said it does happen from time to time where it will not re-learn. If you find that it just can't find an idle, it may have to be reset via Consult II.
 

·
Registered
Joined
·
895 Posts
turn off the radio, lights, roll the drivers side window up and unplug everything from the cigarette lighters, i had a devil of a time till i realized my stereo was on and my satellite radio was plugged in, also try to have it as level as you can. those are my tips.
 

·
Registered
Joined
·
2,123 Posts
I've cleaned my TB a few times, the re-learn always worked. The last time however, it did not. Some how my TB "lost communication (all the tech said)" and would not re-learn, it free revved from 1500-2000 RPM and just could not find an idle.

The techs had to reset it with Consult II. The tech mentioned that the TB of course needs to re-learn idle every time it is unplugged and cleaned but he said it does happen from time to time where it will not re-learn. If you find that it just can't find an idle, it may have to be reset via Consult II.
That's exactly what happened to me. I had to go to Nissan to get it fixed, the OP might have to bite the bullet and do the same.
 

·
Registered
Joined
·
1,114 Posts
That's exactly what happened to me. I had to go to Nissan to get it fixed, the OP might have to bite the bullet and do the same.
They checked everything out that I did, said good work and it took them like.. 5 mins to fix it.

$139 :yuck:
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #18 ·
I unplugged the battery for an hour and replugged. That cleared the codes, pedal dance still didnt work. I'll try a few more times before taking it to Nissan. I really don't want to give them $95 to fix this... (that's what they quoted me on the phone)
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #19 ·
What would be helpful is a video of someone doing the pedal dance in a se-r with the exact procedure and real time timing (no jump cuts)! Oddly enough, just by driving it, the car seems to be doing better. Not perfect. If I have time this weekend I'll dance all over the pedals and see if I can get it. If not, It'll have to wait until I can take it to the dealer. I REALLY REALLY dont want to take it in just for a relearn...thanks for all the advice thus far!
 
  • Like
Reactions: jackson1985
1 - 19 of 19 Posts
Top