A Nissan Sentra Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
2004 spec-v

P0300 code
All coils tested and passed
Have spark at all plugs
Both crank and cam sensors are less than 6 months old(tested good)
Injectors tested good
All injector terminal 1 voltages = 12.45V
All injector terminal 2 voltages = 2.45V

Just finished a rebuild, started it up and had a misfire on cyl/4, coil tested bad.

After replacing cyl/4 coil ran good for about 10 minutes then had a new misfire issue, got code p0300 narrowed it down to cyl/3, spark was good but noticed the cylinder was dry while turning it over.

Pulled rail and injectors, only cyl/1,2,4 injectors sprayed while turning over, plugged injector 4 connector into injector 3 and it sprayed fine.

The service manual says there should be continuity between injector terminal 2 and ECM terminals 22, 23, 41, 42.
The problem with this is while i had continuity between injector terminal 2 and ECM terminals 23, 42, the ECM terminals 22, 41 are blank spaces. Is this normal?
 

·
Registered
Joined
·
550 Posts
no that is not normal you are not supposed to have blank spaces so start checking for a broken wire somewhere or bad grounds on your harness, stuff like this has happened to me twice already on my spec first time it was a broken wire the second time it was bad ground... did you already checked the fuse block connector M1 and the 10A fuse? also what about the harness connectors mentioned did you checked them 2? sometimes they dont click properly and things get messy
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
If the fuse was trash none of the injectors would spray. Just for the hell of it i checked for continuity between cyl/3 injector harness terminal 1 and the fuse 17 in the junction box and its fine so no breaks in the wire.
The injector harnesses were all fully inserted and clipped securely.
There are literally nothing in terminal positions 22 and 41 on the female side of the ECM connector. They couldn't have gone anywhere. Are there any known stock variations to the ECM wiring?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Ideas anyone?

Also i checked out the 2003 fsm just in case some parts (i.e. ecm) were carried over and caused the pin-out to be different but the ecm harness is completely different so thats ruled out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Figured out pin-out

Alright i figured it out, i have continuity between:
- Batt/fuse 17 and terminal 1 on injector harness
- terminal 2 on Injector 1 harness and terminal 23 on ecm harness
- terminal 2 on Injector 2 harness and terminal 42 on ecm harness
- terminal 2 on Injector 3 harness and terminal 22 on ecm harness
- terminal 2 on Injector 4 harness and terminal 41 on ecm harness

Anyone have any clue what else might be the issue?
 
1 - 6 of 6 Posts
Top