A Nissan Sentra Forum banner

28001 - 28020 of 28044 Posts

·
Registered
Joined
·
1,075 Posts
How fucking lucky am I!? commuted back from work and as I was backing up into my driveway i lost ALL POWER. Looks like I need a new ground wire XD

Guess it's time for me to start playing the lottery.
 

·
Registered
Joined
·
4,836 Posts
I made 5th on one of the lists :LOL:. Hollywood here I come.

I have never seen a thick ass wire break like that. That thing looks sheared off ??
 

·
Super Moderator
Joined
·
5,082 Posts
had to verify what I saw on my phone from on my laptop, that break is way to clean in the image and it looks like it should have been inserted further in on the terminal.
 

·
Registered
Joined
·
1,075 Posts
I am guessing it is due to the vibrations, for a few years I used a battery tie down from walmart that was rubber top bracket and after 2-3 years it snapped, when i redid the tie down and replaced it with an all metal bracket from Pboys I did notice that at the crimp it was loose but thought nothing off it.

Guess through the years the rubber bracket allowed the battery to move and prolly each strand of copper broke off.

The bracket i used looks exactly like this before it snapped and swapped it out with an all metal:


on my way from work my radio was cutting out and restarting. I was lucky that it completely broke off/lost contact when I got back home.

When i looked over my power in the drive way and check if my terminals were fine after checking the batt fuse i noticed the ground wire moved while I was untightening the ground terminal, then i looked at the chassis ground and started facepalming hard.
 

·
Registered
Joined
·
1,948 Posts
Ok, so I'm not sure if I'm doing something wrong but I can't get alternator heat shield to fit. It's hitting the ac line and my dipstick tube. Seems pretty basic install so wth lol.
 

Attachments

·
Registered
Joined
·
8,815 Posts
This is SC V2 heat shield
You might have to bend/push the line and dip stick

Sent from my SM-G935U using Tapatalk
 

·
Super Moderator
Joined
·
20,851 Posts
Someone had a post 9n Facebook about theirs not fitting. I didn't ever see what happened there.

I assumed it just needed to extra tweaking but idk

Anyway.....as Kaz said....you can bend that stuff out of the way a little. Or you maybe can adjust the shield a little.

If you need contact for Steven, I can message him on Facebook for you.
 

·
Super Moderator
Joined
·
20,851 Posts
I can't find that Facebook post.
So I assume whatever the issue was got resolved.

Holler at Steven if you are concerned. He won't mind.
 

·
Registered
Joined
·
10 Posts
@SC concepts can you provide some input on my V2 heat shield dilemma.
Hey, sorry your having a few issues. You do need to slightly bend the AC line and dipstick tube to get proper spacing for the shield to fit. I apologise for not making this clear. If you still have issues after moving those parts, please email me directly at [email protected] and I'll get you taken care of.

Sent from my GM1915 using Tapatalk
 

·
Registered
Joined
·
4,836 Posts
Why the hell does my car keep killing coils? Been trying to find a very elusive miss for months. Just let it sit while I drove my other car.

Last night I finally found it was #1 coil. Pulled it and no spark. Replaced with a questinable used one. It was bad and in never sparked. Replaced with another. After 15 mins of driving it was dead. Replaced with another third one on that drive and just made my way home. I was scared to drive it to work today.

Something is killing coils. Missing and dying seems random. Wire wiggle test shows nothing. I fear its a corroded connector somewhere with too much resistance or the main ground wire that burns them out. Any ideas?
 

·
Registered
Joined
·
10 Posts
Why the hell does my car keep killing coils? Been trying to find a very elusive miss for months. Just let it sit while I drove my other car.

Last night I finally found it was #1 coil. Pulled it and no spark. Replaced with a questinable used one. It was bad and in never sparked. Replaced with another. After 15 mins of driving it was dead. Replaced with another third one on that drive and just made my way home. I was scared to drive it to work today.

Something is killing coils. Missing and dying seems random. Wire wiggle test shows nothing. I fear its a corroded connector somewhere with too much resistance or the main ground wire that burns them out. Any ideas?
Hey, the first gen coil packs aren't very reliable. Lots of people have this same problem. You could check all your grounds and make sure they are tight and not corroded. Also, check your fuse box to make sure nothing has melted causing an issue. If your interested, I sell upgraded coil-on-plug setups using GTR coil packs. Good for 1000hp, so they will be perfect for your daily driver. I also sell new harness connectors if yours are bad. Pm me or check out the site sconcepts.bigcaftel.com

Sent from my GM1915 using Tapatalk
 

·
Registered
Joined
·
411 Posts
Hey, the first gen coil packs aren't very reliable. Lots of people have this same problem. You could check all your grounds and make sure they are tight and not corroded. Also, check your fuse box to make sure nothing has melted causing an issue. If your interested, I sell upgraded coil-on-plug setups using GTR coil packs. Good for 1000hp, so they will be perfect for your daily driver. I also sell new harness connectors if yours are bad. Pm me or check out the site sconcepts.bigcaftel.com

Sent from my GM1915 using Tapatalk
These are the same coils that alot of LS guys swap to. You will not have coil issues with these.

That being said, do not replace your stock coils with autozone or oreilly.

They are mere shells compared to OEM NISSAN. Also if you decide just to buy OEM, buy from Nissan.
 

·
Registered
Joined
·
1,075 Posts
replaced a section of my hose between the oil catch and intake plenum. the bend is so insane that it collapses no matter what so I did a Bill O'Reilly and said "FUCK IT!"

Brazed some copper piping and fittings with 15% silver content i had around when i used to do HVAC and replaced the entire bend, the idle is so much smoother now that there is actual vacuum flow, pics tomorrow after or before i set sail to a collectors convention. I collect Transformers toys, don't judge me, I love this shit.
 

·
Registered
Joined
·
3,025 Posts
Just came back from a comic book store. Aint been to one since I was a preteen. My favorites were Avengers and Secret Wars. Come to find out they sell for like $100+ now. Gave all mine away when I was a kid.

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
319 Posts
I collect Transformers toys, don't judge me, I love this shit.
Do you have an Autobot or Deceptacon badge on your Sentra ?
My son started loving Transformers when he was about 5 and we got a large Autobot badge for the rear and 2 small badges for the side panels of the 4WD.
 
28001 - 28020 of 28044 Posts
Top